Symptoms
- When trying to set up an IMAP account in Outlook or Samsung Email android app, IMAP option is not available in the “Account type” field
- One of the following errors can be found in
/var/log/maillog
on Plesk server:server dovecot: imap-login: Disconnected: Inactivity during authentication (client didn’t finish SASL auth, waited 179 secs): user=<>, method=DIGEST-MD5, rip=127.0.0.1, lip=127.0.0.1, TLS, session=<Uzcj+sRVW+J/AAAB></>
imap-login: Disconnected (auth failed… The issue is not reproduced in other mail clients, like Thunderbird.
SASL DIGEST-MD5 authentication failed: authentication failure
Cause
Current implementation of a DIGEST-MD5 authentication in libsasl2-2 package is incompatible with Microsoft Outlook. Additional details can be found here.
Resolution
Note: if you don’t have root access to Plesk server via SSH, contact your hosting provider regarding the issue
- Login to Plesk server over SSH
- Create a custom configuration file and place the
auth_mechanisms
parameter without digest-md5:# vi /etc/dovecot/conf.d/00-auth_mechs.conf
auth_mechanisms = plain login cram-md5 apop
- Restart Dovecot to apply the configuration changes:
# service dovecot restart